Back to overview
Degraded
Kern family healthcare portal down
Mar 22, 2026 at 06:42pm UTC
Affected services
Eligibility Verification Services
Resolved
Mar 22, 2026 at 06:58pm UTC
We’re back! kern family eligibility should be up and running. Thanks for bearing with us.
Affected services
Created
Mar 22, 2026 at 06:42pm UTC
We’re having some trouble with kern family healthcare portal. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services